Sansui SR 636-Warp Speed!

Post Reply
User avatar
Knifeswitch
Posts: 31
Joined: Sun Mar 07, 2021 12:40 pm

Sansui SR 636-Warp Speed!

Post by Knifeswitch »

Friend of mine asked me to take a look at this. Nice older deck and when behaving, maintains a steady lock on both speeds. Pots work as they should. Problem is once in a while it will just go hog wild fast. Shut power off and restore, returns to normal. But it will go wild again. This is PLL quartz lock direct drive. I’ve witnessed the dirty pot drift in other decks but I don’t think that’s what’s going on here. Suggestions?
Mike
Hugo
Posts: 187
Joined: Sun Feb 28, 2021 10:20 am

Re: Sansui SR 636-Warp Speed!

Post by Hugo »

You still need to exclude the pot as possible cause. Use Deoxit D5 to clean it.
User avatar
Knifeswitch
Posts: 31
Joined: Sun Mar 07, 2021 12:40 pm

Re: Sansui SR 636-Warp Speed!

Post by Knifeswitch »

Yes, the first thing I did after initial inspection. Now I can’t recreate the problem YET. Gotta love the intermittent problems🥴 Maybe I solved it but I’m going to scope it, check voltages and a quick check of the power supply caps. I have the schematic.
Hugo
Posts: 187
Joined: Sun Feb 28, 2021 10:20 am

Re: Sansui SR 636-Warp Speed!

Post by Hugo »

Just hook it up to your stereo and start using it. If it works well for a week, then it is fine.
User avatar
Knifeswitch
Posts: 31
Joined: Sun Mar 07, 2021 12:40 pm

Re: Sansui SR 636-Warp Speed!

Post by Knifeswitch »

It’s back home now playing nicely which is good. Back to my project
Post Reply